Coordinate reversion?

Discussion of FieldGenius related issues and questions.

Moderators: Brian Sloman, Jason Poitras, James Johnston

Coordinate reversion?

Postby Ned Ferguson » Tue Dec 26, 2006 2:11 pm

I am having a serious problem with FieldGenius that I will try to communicate as best I can. I am still trying to wrap my brain around it myself. I have a job (topographic) which I did alone using a combination of the new Topcon Robotic GPT 9005A and Topcon HiperLite RTK. Using AllegroCE with v. 3.0.1 (2006-11-27)

Day 1:
Shot points 1-244 with Robotic - no problems.

Day 2 (before lunch):
After analyzing the data in the office, I uploaded an ascii file with rotated coordinates, then imported the ascii file into FG, telling the program to overwrite the points. No apparent problems so far. I then set up the RTK and shot 4 control points in common and adjusted the RTK points to the ground coordinates. I spend the next several hours staking out calculated points looking for more evidence, some of which I found. I did some limited as-built and broke for lunch (points 259-283). Still no problem so far.

Day 2 (second half):
I set up the RTK base on the same station. I gave FG a new antenna height and continued doing the job as I had done before. The first point after lunch with the new seup is 284. At point 322, I noticed the points were not coming out on the screen where they should. Something is wrong, I muttered to myself. I staked out one of my control points. FG is telling me the point is way off from where it should be. I start cursing about this time. I look in the transformation settings at the parameters. They look the same as far as I can remember (the SF had not reverted to 1.000 as I hade expected) but the residuals are now way off. This happened by itself. I figured FG has somehow reset the transformation parameters, but I really did not know how.

I attempted to fix the problem by simply clicking "calculate parameters" again. The risiduals now look good again. Figuring this worked OK, I staked out another control point just to be sure. Sure enough, the control point stakes out OK. Now satisfied, I continue with the rest of the job thnking everything is a-ok.

Back at the office:
I upload points to my computer, thinking that I only have a small group (284-322) that will be out of place. On the contrary, I seem to have points all over the place. In fact most of the job is rotated incorrectly. This is inexplicable to me. Knowing that I had staked caclulated points in the field, and that they came out exactly where I had expected, I could not understand how this could possibly be.

I examined the raw data. All the SP point records show up correctly, verifiing that I uploaded the rotated points correctly.

After looking carefully at the raw data and comparing the coordinates now in the data collector, it seems that I was incorrect in assuming the RTK transformation parameters were off.

Now read carefully.

What had actually happened is that the coordinates that I had uploaded earlier had reverted back to their old values by themselves. By re-transforming the RTK points, I actually put the job back on the assumed rotation I had sarted with on the first day. This apparently happened somehow when I began the new setup after lunch.

I now have several groups of points with mystery rotation that I am trying to figure out what to do with. There is no evidence of any of this "reversion" occuring in the raw data. I do not want to have to re-shoot the job. This little quirk has cost me untold hours of grief. I am still trying to figure out what happened. I just hope I can.
Ned Ferguson
Posts: 37
Joined: Wed Mar 01, 2006 6:35 pm

Postby Ned Ferguson » Tue Dec 26, 2006 3:51 pm

The good news is that writing all that down helped me to formulate a plan and realize what happened. I recovered the data. This seriously took the wind out of my sails today.

The "reversion" theory is still the only one that makes sense to me. The pre-lunch coordinates and observations were all correct. The post-lunch coordinates were wrong.
Ned Ferguson
Posts: 37
Joined: Wed Mar 01, 2006 6:35 pm

Postby Jason Poitras » Tue Jan 02, 2007 12:59 pm

Hi Ned,

Could you send me your FieldGenius project so I can examine it.

I have two questions:

Did you do any raw file editing in FieldGenius and then recoordinated it?

Did you use the transform functions which is accesible from the coordinate editor?

Another suggestion I have so you get faster service is to go to and create a support ticket. Posting technical support questions on our user forum isn't always the best place to get immediate answers to your questions.
Jason Poitras
General Manager
[email protected]
User avatar
Jason Poitras
Site Admin
Posts: 443
Joined: Tue Oct 29, 2002 5:17 pm
Location: Kelowna, BC, Canada

Postby Ned Ferguson » Thu Jan 04, 2007 10:44 am


Thanks for the response.

Did you do any raw file editing in FieldGenius and then recoordinated it?


Did you use the transform functions which is accesible from the coordinate editor?

No. All I did was turn the data collector on/off and begin a new setup. Then as I described, I recalculated the transformation parameters from the settings>> GPS local transformation screen. I did not apply the new parameters to any existing points, just used them for the points I collected going forward.

I will forward you the project directory. I am very curious to understand what happened here.

Ned Ferguson
Posts: 37
Joined: Wed Mar 01, 2006 6:35 pm

Return to FieldGenius

Who is online

Users browsing this forum: No registered users and 1 guest