Bug Fixes & suggested Improvement for MSCAD2008

Discussion of MicroSurvey CAD related issues and questions.

Moderators: Brian Sloman, Jason Poitras, James Johnston

Bug Fixes & suggested Improvement for MSCAD2008

Postby DKNTEC » Thu Jul 19, 2007 1:27 pm

in MSCAD2005 SP1.3
I post this here instead of in Bug Fix for anyone else who has comments to add.
With MSCAD2008 on the horizon, we don't need this fixed for 2005, but will look for it in 2008.

Bug#1: MS Bearing labelling
Set Drawing Settings>Drawing Units>Angular Units>Display Precision to 4.
With MS DMS/Dist, label a line that has an actual "dirty" "fractional" bearing of say 1d40'34.9840", It will correctly label it to the rounded off 1d40'35".
Now set the Display Precision to 8 & label it. It will now label it as 1d40'34". It is incorrectly rounding down. This is repeatable.
I find if the the fractional second is below 0.5" it seems ok, but if above 0.5" the problem arises. Test all scenarios though to confirm the parameters.
This bug has been here since InCAD 12 DOS days, and has always "bugged" me. I was aware of it & just lived with it.

Smaller Bug #2
I always set my angular units to clockwise & 270d North, so that IntelliCAD List command reports correctly.
I know this is contrary to IntelliCAD's defaults, but I'm a surveyor & that's the way I want to see the numbers listed! It usually works ok.
But I find these settings occasionally "bust" or revert to 90d South, sometimes to counter-clockwise, & once in awhile to some oddball bearing, for reasons I don't fully understand.
This has been reported here in the Forum previously by others.
I am aware of this bug, frequently check & reset it when needed, & can live with it if you can't fix it, (it is not really a big deal if you know about it) but please also fix these "busts" if you can.

Suggested Improvement for 2008:
This is related to Bug 1 above.
MS Labelling Defaults>Bearings>Seconds Rounding:
Currently, the smallest this can be set to is an integer of 1 - 0d00'00".
Please upgrade this to be able to label "fractional" seconds i.e. 0d00'00.0001" to match Drawing Settings Bearings Display Precision of 8.
Distances can label to 8 decimal places, why not Bearings too?
Rational;
For survey accuracy in the field, 0d00'01" is nothing, finer than I can measure with my old 10 second gun in construction surveys.
I label output drawings to usual standard of 1"
However, for my own CAD working drawings, i.e. when debugging a traverse, or matching up geometrics, or wanting to build a drawing line with a "clean" bearing i.e. 45d00'00.0000", I sometimes want to know, label & see the full bearing to the fractional second i.e. the 1d40'34.9840" noted above.
The only way I can do it now is set display precision to 4, MS label it, reset display precision to 8, List it to see what the "fractional" amount is, & then manually edit the bearing label. Then reset Display Precision back to 4 so the next label doesn't "bust". Tedious & prone to errors!
This is how I first came across Bug#1 above years ago.
Thx
I look forward to MSCAD2008!
DKNTEC
 
Posts: 32
Joined: Thu Sep 28, 2006 12:08 pm
Location: Kaleden, BC Canada

Postby Brian Sloman » Fri Jul 27, 2007 3:51 pm

I have reproduced your first bug and reported it on to our programmers. I could not reproduce your second bug, but if you can provide any additional details on when the values change (ie, after running a particular command) then I can look into it some more. The ability to label bearings with decimal seconds is already on our wish list.
User avatar
Brian Sloman
Product Manager
 
Posts: 399
Joined: Fri Jan 07, 2005 4:42 pm
Location: Westbank, BC, Canada

Is there a work around for this bug yet?

Postby BSMITH-VISTA » Wed Nov 18, 2009 2:19 pm

Hi,

I am new to IntelliCad and MicroSurvey CAD 2010. I come from an Autodesk background with LDD 2007, 2008, 2009 and Civil 3D 2010.

I try to change my angular settings to the 270d and clockwise angles (Call me silly but survey 101 taught me turn my angles right all the time). When I try to make these changes, anything over 180d reverts to it's similar angle in it's opposite quadrant (ie. that is if I enter 270d it reverts to 90d, if I enter 181d it reverts to 179d, if I enter 269d it reverts to 91d, if I enter 271d it reverts to 89d... and so on.)

This bug is a bit of a pet peeve for me as it wastes time having to calc proper azimuths. In the survey world I come from...... North is up!

Any suggestions to work around this would be greatly appreciated.
BSMITH-VISTA
 
Posts: 3
Joined: Tue Oct 20, 2009 1:46 pm

Postby fjt_aus » Mon Nov 23, 2009 3:14 pm

This drawing setting drove me nuts for years when I was just using Intellicad (without Microsurvey).

In your drawing settings: all you need to do is set your angular units to clockwise and type in your angle base as 0°00'. This will make the little pointer point to the east (annoying, I know). Leave it like this forever.

In your Microsurvey settings: as long as you have Microsurvey set to azimuths and enter your bearings using Microsurvey commands (eg CAD LINE DIALOG>TRAVERSE) everything will work as it should.

Just think of the drawing setting as something which controls cad entities. For example... the angular setting for a piece of text which is written from left to right across the page is 0°00'. Hope this helps.
fjt_aus
 
Posts: 32
Joined: Fri Oct 27, 2006 8:24 pm
Location: South Australia

Thanks fjt_aus!

Postby BSMITH-VISTA » Mon Nov 23, 2009 3:24 pm

That is a very simple and straight forward answer. I will try it.
Thanks for your input and it is greatly appreciated.

Brad 8)
BSMITH-VISTA
 
Posts: 3
Joined: Tue Oct 20, 2009 1:46 pm

I have figured this one out!

Postby BSMITH-VISTA » Tue Dec 29, 2009 2:36 pm

Ok, here it goes:
1) Go to MSTools menu
2) MicroSurvey Assistant main menu
3) Set Program Defaults
4) Drawing Units
5) Change settings for: Angular Units
6) Select Angle Direction as: Clockwise
7) Switch radio button under Unit Types to: Surveyor's Units
8.) Click in Angle Base field and type "S", then click in the Display precision field box. The program will automatically switch the Angle Base field to something else like 'N' or 'E'.
9) Change it back to 'S' again and then click on the Degrees/Minutes/Seconds radio button under the Unit Types.

Poof! Problem solved. The program will now recognise the 'Real World' Azimuths that you traverse in, where North is uuuuuhhhhh....... REALLY NORTH!

Don't Forget To Save!
8)
BSMITH-VISTA
 
Posts: 3
Joined: Tue Oct 20, 2009 1:46 pm


Return to MicroSurvey CAD

Who is online

Users browsing this forum: No registered users and 2 guests

cron