deleting in MSCad 2005

Discussion of MicroSurvey CAD related issues and questions.

Moderators: Brian Sloman, Jason Poitras, James Johnston

Post Reply
ergols
Posts: 27
Joined: Tue Jul 22, 2003 8:05 am

deleting in MSCad 2005

Post by ergols » Fri Jul 08, 2005 5:49 am

When I delete items (text, objects, lines, etc) in a drawing I'm finding items that I haven't selected are being deleted !!!? I hit enter to complete the command and items that clearly were NOT selected disappear from the drawing. This isn't my first time using cad. Any idea what the hell is going on?

ergols
Posts: 27
Joined: Tue Jul 22, 2003 8:05 am

Magical disappearing act

Post by ergols » Fri Jul 08, 2005 6:28 am

I repeated this a few times to see exactly what's happening. After I select one or two items, they show on the screen as having been selected. Then when I hit the enter key to complete the command they disappear. So far, so good. Then I selected the pan command to move across the drawing. Other items disappear off of the screen as soon as I pan. Items that were NOT selected. It's a cute trick, but it's not really what I want. What's up?

Glen Cameron
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada
Contact:

deleting

Post by Glen Cameron » Fri Jul 08, 2005 6:39 am

Are the tiems gone prior to panning? Are you selecting items using Window, Corssing, or what? Are the items a block or a group?
Do you have entity snpas on and if so try it again with them off.

I don't know what else to say right now. Obviously this is not normal and we have not run into this before.

Cheers,
Glen W. Cameron, C.E.T.
City of North Bay, Ontario

ergols
Posts: 27
Joined: Tue Jul 22, 2003 8:05 am

The lost is found

Post by ergols » Fri Jul 08, 2005 6:39 am

This just keeps getting better. If I select the area of the drawing containing the disappearing item (of course I have to know where this is, and if I can't see it, . . .) then I see a greyed selected item with a grip !!! I then hit <esc> to exit the selection and the invisible object re-appears !!! Either this is a program bug or my computer has a really peculiar virus that just likes to pick on my Microsurvey program.

ergols
Posts: 27
Joined: Tue Jul 22, 2003 8:05 am

Disappearing act somehow connected to viewing functions

Post by ergols » Fri Jul 08, 2005 6:48 am

Ok, so I click on the invisible items, they "re-appear" as greyed items with a grip handle on them, I hit the <esc> key, and they re-appear, looking normal. Then I pan, they disappear. Ok, I zoom extents instead of panning. Oh, look, they disappear again. This oddity seems to have something to do with some of the viewing functions.

Glen Cameron
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada
Contact:

deleting

Post by Glen Cameron » Fri Jul 08, 2005 7:36 am

If you run the REGEN command do they appear on screen?
If you save the drawing, exit the program, restart the program and reload the job, do they work as normal?
Is this happening in only one drawing or many drawings?

If it is only this one drawing then maybe it is corrupt. If it is many drawings then maybe a program file has become corrupt. If so then you may wish to uninstall the program and try reinstalling it again.

If this were a bug I would be seeing many calls on this - and i am not. So it sounds like either a corrupt drawing or corrupt program file.

Cheers,
Glen W. Cameron, C.E.T.
City of North Bay, Ontario

rwhatman
Posts: 299
Joined: Sun Nov 10, 2002 6:41 am
Location: Peterborough, Ontario, Canada

Post by rwhatman » Fri Jul 08, 2005 8:09 am

You may be picking option OUTSIDE WINDOW

This option deletes everything outside window.

I find that I don't need all the options.

So I turned off Display Prompt Boxes.

Just right click on the command area and pick options
then Display tab , then turn off Display Prompt Boxes.

May not be this, but some of thoes option missed me up.

ergols
Posts: 27
Joined: Tue Jul 22, 2003 8:05 am

Disappearance

Post by ergols » Fri Jul 08, 2005 8:41 am

The text, objects remain invisible after a regen. This is happening in any drawing that I open and perform editing commands on. I used the selection then escape command to make the objects visible and then I printed the drawing into a pdf. The "visible" objects, which I could see before AND after printing the drawing did NOT show up in the pdf version of the drawing. I am ONLY using the item select command to reproduce this problem. I already thought of the possibility that the window crossing selection was malfunctioning and tried erasing by only using the individual item select. Erasing by individual item selection alone also causes random objects to disappear.

Glen Cameron
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada
Contact:

deleting

Post by Glen Cameron » Fri Jul 08, 2005 11:00 am

Is it possible that we are talking about the IPN, IPD, and IPE text?
Independant Point Numbers (IPN) do not plot. Try typing in IPN and see what happens. Do the point numbers (yellow text) vanish or come up or what?

Cheers,
Glen W. Cameron, C.E.T.
City of North Bay, Ontario

Post Reply