[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
MicroSurvey Software Inc. • View topic - Drawing 0

Drawing 0

Discussion of MicroSurvey CAD related issues and questions.

Moderators: Brian Sloman, Jason Poitras, James Johnston

Drawing 0

Postby Eric Anderson » Fri May 21, 2004 6:25 am

Everytime I go to close MSCAD it asks me if I want to save Drawing 0. Is there a way to disable that? It's mildly annoying to have to say no everytime I shut MSCAD down.

Thanks
Eric Anderson
Senior Survey Technician
Olmsted County Public Works
Rochester, MN
User avatar
Eric Anderson
 
Posts: 97
Joined: Wed Feb 12, 2003 11:25 am
Location: Rochester, MN

Drawing_0

Postby Glen Cameron » Fri May 21, 2004 6:41 am

When you first start MSCAD2004 up, it defaults to an empty drawing called Drawing_0. If you are starting a new job all you need to do is save it to give it a name of your choice. This allows us to create the database that goes along with the drawing.

If you wish to open an existing job to continue working in it, I would suggest closing the Drawing_0 (pick the small X in the top right corner of the job), then open your desired job. If you don't do it then, when you exit from MSCAD, that drawing_0 will still be open and you will need to close it at that time.

Most Windows programs (such as Word, etc.) do start up with an empty document that you can work in directly, then save it later with a name you choose. The CAD Engine we use is doing the same thing. We require a name for the database side of things (that is why you have to save it before you can do any survey work), or you need to close it to open an existing job (or it remains open untill you exit the program).

There is no way to change this operation permanently. This was also the reason we had to stop using our Project Manager, which we have had for several versions.

Cheers,
Last edited by Glen Cameron on Mon May 24, 2004 11:52 am, edited 1 time in total.
Glen W. Cameron, C.E.T.
City of North Bay, Ontario
Glen Cameron
 
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada

Postby Eric Anderson » Fri May 21, 2004 7:12 am

Thanks. :)
Eric Anderson
Senior Survey Technician
Olmsted County Public Works
Rochester, MN
User avatar
Eric Anderson
 
Posts: 97
Joined: Wed Feb 12, 2003 11:25 am
Location: Rochester, MN

Postby rwhatman » Fri May 21, 2004 7:17 am

When opening a EXISTING DRAWING use your Browser. Just go to the drawing you want and click on it twice and it will load the drawing.

You won't get the Drawing_0

I only start the Mscad program if I am starting a NEW drawing.
rwhatman
 
Posts: 299
Joined: Sun Nov 10, 2002 6:41 am
Location: Peterborough, Ontario, Canada

Postby T.M. Moretz » Fri May 21, 2004 4:54 pm

:idea: Great idea Richard.
T.M. Moretz
 
Posts: 79
Joined: Fri Nov 08, 2002 1:31 pm
Location: North Carolina, USA

Drawing_0

Postby John Gallagher » Sat May 22, 2004 1:55 pm

If you're daring,go to the windows folder and find the mscad2004.ini file.
Open it up in Notepad or Wordpad and look for the line that starts

New in FelixCAD 6.0

Change AutoNew=1 to AutoNew=0 and that eliminates the new drawing starting up when you start MSCAD.
Be forewarned though,copy the original .ini file to a safe place before making any changes,so far I haven't run into any problems but if I do the original file is safe and sound on my hard drive and on a floppy so I can restore it if a problem does crop up.
Hope this helps,
John Gallagher
John Gallagher
 
Posts: 64
Joined: Fri Nov 08, 2002 1:35 pm
Location: Long Island New York

Drawing 0

Postby Vincent Popish » Mon May 24, 2004 8:44 am

Thanks, I didn't care for having to not save the drawing when I closed it, changing the line to 0 works just right. I also changed intro time from 4 to 1, and it cuts the advertisement display time.

Thanks,
Vince Popish
Vincent Popish
 
Posts: 129
Joined: Thu Nov 14, 2002 11:24 am
Location: Grand Junction, CO

Postby rwhatman » Tue May 25, 2004 9:17 am

One word of Caution on changing mscad2004.ini

Every time we have a update this file will likely change back to the original settings. So you might want to keep a copy of the changed
file as well.

The Mscad.cvs file that they send with every update. I like to see it
removed from the updates. I have my own version that I have to copy
over the Mscad version.

Some of the blocks even get sent some times and I have to fix that.

I don't think I going to change that file because it's just another one
that I would have to remember to change.
rwhatman
 
Posts: 299
Joined: Sun Nov 10, 2002 6:41 am
Location: Peterborough, Ontario, Canada

Drawing_0

Postby Glen Cameron » Tue May 25, 2004 11:45 am

John - interesting bit of information. This was not in the original version and had to of been added in one of the service patches. I have tried it here and it works very well. I also passed this info back to the head office. (see, even old dogs like us can be taught new tricks)

So anyone who wants to get rid of the Drawing_0 on startup of the program can now edit the file, as you described, and it solves the issue.

Being it is a simple edit, everyone should be able to do it using either Notepad or Wordpad.

Edit this portion:

;;; New in FelixCAD 6.0 - Create without request a new drawing_? automatically
AutoNew=1
AutoNewName=Drawing_
AutoNewFile=1


To read:

;;; New in FelixCAD 6.0 - Create without request a new drawing_? automatically
AutoNew=0
AutoNewName=Drawing_
AutoNewFile=1


Now keep in mind, being you are changing something to be different than what is shipping, you may need to set it back again in the furture for some features to work (if we add any that require it).

Cheers,
Last edited by Glen Cameron on Tue May 25, 2004 12:12 pm, edited 1 time in total.
Glen W. Cameron, C.E.T.
City of North Bay, Ontario
Glen Cameron
 
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada

Very interesting thread...

Postby Darcy Detlor » Tue May 25, 2004 12:11 pm

Hello,

The MSCAD2004.INI file is not currently replaced for the MSCAD service pack installation, nor is the MSCAD.CSV file.

The files currently replaced include:

- the menus, because of minor errors in the original release
- the dlls created by MicroSurvey
- a number of CAD dlls that are improving the CAD engine and giving AutoCAD 2004 compatibility
- the dialog and menu editor has been improved
- the DWF viewer was improved
- the FieldGenius, IPN, and Ties toolbars
- several CAD toolbars and the measure/divide lisp routine

Another Service Pack is on the way that adds AutoCAD 2005 compatibility. The basic DWG file did not change a great deal, but the OpenDesign organization released an update that includes support for the 2005 version.
Darcy Detlor,
President,
MicroSurvey Software Inc.
darcy.detlor@microsurvey.com
User avatar
Darcy Detlor
Site Admin
 
Posts: 205
Joined: Tue Oct 29, 2002 10:14 am
Location: West Kelowna, BC

Drawing_0

Postby John Gallagher » Tue May 25, 2004 3:15 pm

Glen,
Thanks for the complinent (and from your photo and having spoken to a few times I doubt you fall into the old dog catagory,unlike me).You'll notice in my original post I did mention that the original should be backed up in two places,and advised everyone who tried it to back up the file. (I'm not overly paranoid about computers but you never know!).
Playing with the .ini files is something I've done for years,ever since dos so I don't recommend it to often if I don't know the other person,but I figured the people who use MSCAD must be pretty bright not to buy into the Autocad hype.
By the way,Vince,if you read this,just go up two lines in the .ini file and set the ShowIntro=1 line to 0 and you can eliminate the splash screen altogether.Or,if you want just reset the path for the bitmap file to something else.Right now I have a lovely photo from the hubble space telescope as the opening.
Glen,one other thing that noticed.On my computer at home I have the freebie copy of Felixcad 5 and changing the .ini file freezes the program on boot so this may or may not have some thing to do with any changes your programers made to the cad engine or the .ini file.This is why playing with the file can be dangerous so once again to all who may try it...backup the original and then backup the backup
John Gallagher
John Gallagher
 
Posts: 64
Joined: Fri Nov 08, 2002 1:35 pm
Location: Long Island New York


Return to MicroSurvey CAD

Who is online

Users browsing this forum: No registered users and 1 guest