[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
MicroSurvey Software Inc. • View topic - upload MSC2004 to tds 48

upload MSC2004 to tds 48

Discussion of MicroSurvey CAD related issues and questions.

Moderators: Brian Sloman, Jason Poitras, James Johnston

upload MSC2004 to tds 48

Postby j.heck w/give'mheck, inc. » Mon Sep 13, 2004 7:05 pm

I'm trying to upload a coordinate file to my HP48GX (TDS). Using MSPOINTS drop down menu, I export a comma delineated ascii coordinate file to a folder on hard drive. When I try to upload this file to TDS 48 using MSTRAVERSE drop down menu (upload to DC), I click "browse for upload", select the correct file, click "upload", then click "start sending data now", but I keep getting message that file is not a comma delineated ascii file (I have looked at file using notepad and see no problem with ascii file format). Can you help?
j.heck w/give'mheck, inc.
 

TDS

Postby Glen Cameron » Tue Sep 14, 2004 6:26 am

So the TDS is not seeing the file as an ASCII comma delimited file?

Maybe you have the wrong setting on the TDS to import this file? Can you see if you have other options in the TDS for file formats to import?

Try a TEXT file vs COORDINATE file, as an example. I do not have one of those units here so I can't see or remember all of the options available. But I know it does work with one of them - I am sorry to say I simply don't remember the exact one. (If I heard it I would know it <smile>)

Cheers,
Glen W. Cameron, C.E.T.
City of North Bay, Ontario
Glen Cameron
 
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada

Upload from MSCAD2004 to HP48 (TDS)

Postby J.Heck » Tue Sep 14, 2004 6:46 am

The TDS program lists three options for files to be uploaded, crd (coordinate), raw (raw data) and plst (point list). I have tried both crd and plst but keep getting the following error message in MSCAD (not TDS) "This file does not appear to be a comma delineated ASCII upload file. No conversion of this file will be performed".
J.Heck
 

TDS

Postby Glen Cameron » Tue Sep 14, 2004 8:31 am

Instead of exporting an ASCII file that way you were doing it - try going to the MsTraverse menu -> Write Collector Files Out -> TDS 48 & 500.
Then see if this file will upload for you.

Cheers,
Glen W. Cameron, C.E.T.
City of North Bay, Ontario
Glen Cameron
 
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada

Upload MSCAD2004 to HP48 (TDS)

Postby J. Heck » Tue Sep 14, 2004 9:28 am

I am using the following procedure to upload coordinate data to my HP48GX (TDS).
1. MSTRAVERSE drop down menu - write collector files out - tds 48 & 500
2. At prompt: enter name of TDS Create Upload file file, I select the current job's *.msd file and click save. It states that the file already exists, do I want to overwrite and I choose yes (as previously stated, I have also tried saving (exporting) data to a comma delineated ascii coordinate file, selecting it, with the exact same results).
3. I return to the MSTRAVERSE drop down menu, select "upload to dc" and follow the procedures that I explained in my first posting. After hitting the receive button on my HP48 and the "start sending data now" prompt in MSCAD, I get the message that the file does not appear to be a comma delineated ascii upload file.... Can you determine what I'm doing wrong?
Thanks,
Jeff>
J. Heck
 

TDS

Postby Glen Cameron » Tue Sep 14, 2004 9:51 am

When asked "enter name of TDS Create Upload file", you must give a new file name (the file to upload), do not pick the MSD file (this is the existing database file). I would suggest using the name of the file with the extention of TXT or something similar.

Once the file name is given you should then be asked for the point range to export, on the command line. Once completed, pres ESC to exit the command.

Then do the upload as you have described, picking this new file name to upload.

Cheers,
Last edited by Glen Cameron on Wed Sep 15, 2004 4:38 am, edited 1 time in total.
Glen W. Cameron, C.E.T.
City of North Bay, Ontario
Glen Cameron
 
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada

Upload MSCAD2004 to HP48GX (TDS)

Postby J.Heck » Tue Sep 14, 2004 12:40 pm

Saved the files but changed the extension to .txt. I was prompted to give a range of points to export. Set the range and saw the points fly by on screen. Tried to upload to data collector, same message "does not appear to be a comma delineated ascii upload file". Tried again with .asc extension to file. Same result. Is there a setting within MSCAD that determines format of upload file (comma delineated, space delineated, etc) that I can check?
J.Heck
 

Postby John Gallagher » Tue Sep 14, 2004 1:30 pm

I'm writting this from home,so can't check it out until tommorow morning at work,but I seem to recall reading somewhere that the TDS won't recognize a coordinate file unless it has the extension .cr5
Try renaming the file to this and see if it works.
Hope this helps some,
John Gallagher
John Gallagher
 
Posts: 64
Joined: Fri Nov 08, 2002 1:35 pm
Location: Long Island New York

TDS upload

Postby Dave Morris » Tue Sep 14, 2004 1:58 pm

Its been awhile since I used the Hp48, however we use a leica instrument with TDS on board, If I remember corrrectly, the coordinate file .CR5, is not an ASCII file but binary. We use a routine supplied from Lieca to convert from ASCII to CR5 and back to loaded on instrument.
Dave Morris
 
Posts: 8
Joined: Thu Sep 02, 2004 3:33 pm
Location: Charlottetown, PEI

Upload from MSCAD2004 to HP48GX (TDS)

Postby J.Heck » Tue Sep 14, 2004 5:11 pm

Thanks for the tips but still no upload. MSCADD 2004 has the option of saving to a TDS binary file. I tried this procedure (MSTRAVERSE - Write Export file) and was told that the conversion file must be an ascii file created by "export ascii file" under points menu. Exported the ascii file again, but every time I try to run the conversion, I get the message that the file is not a comma delineated ascii file, no matter what file name or file extention I use (asc, txt, cr5). I am highlighting all of the correct options in creating the exported ascii file and I can view the file in notepad and it is a comma delineated text file. Why won't MSCADD 2004 recognize it as such and convert to a CR5 file?
J.Heck
 

TDS

Postby Glen Cameron » Wed Sep 15, 2004 4:36 am

I just walked through the steps myself. Please see if they help you if you follow them as well.

I used the MsTraverse menu -> Write Collector Files Out -> TDS 48 & 500.

I saved the file name as TDS-1.TXT

The file is automatically a comma deliniated file.
I exported 10 points only - see them here:

1,87.6023836900,383.7720634807,-210.0000000000,
2,53.2006260056,517.5566766977,-210.0000000000,GLEN
3,68.4902960875,371.5403274152,-210.0000000000,GLEN
4,34.8530219073,454.1045458576,-210.0000000000,GLEN
5,-39.3018779901,498.4445890953,-210.0000000000,GLEN
6,116.6527568456,609.2946971893,-110.0000000000,GLEN
7,-23.2477244041,723.9672228039,-110.0000000000,GLEN
8,96.4015718606,625.8940291443,-110.0000000000,
9,95.3099500606,594.1245649155,-110.0000000000,
10,83.7230127628,610.4261870451,-110.0000000000,

Then I went back to the MsTraverse menu -> Write Collector Files Out -> TDS CR5 Binary File.

On the first dialog that comes up, I entered in (or used the browse button) the name of the file I had already exported (from above, it was called TDS-1.TXT).

I then pick on the CONVERT button and I get a dialog telling me:

"This File has Just been Created
C:\SAMPLES\TDS-1.CR5
This is a Binary, non-Sequential, TDS 48 Coordinate file.
This file is ready for uploading to your PCMCIA card, FS/2 or FS/3"

The CR5 file is created on my system and is available for me to copy to a suitable collector.

If this does not work for you then I would begin to suspect that you may have a bad install of the program or something else is interferring with the program.

Cheers,
Glen W. Cameron, C.E.T.
City of North Bay, Ontario
Glen Cameron
 
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada

Upload MSCAD2004 to TDS

Postby J. Heck » Fri Sep 17, 2004 10:28 am

Glen,
Followed steps as listed (even as far as naming the file tds-1.txt). When I chose MSTRAVERSE>write collector file out>TDS CR5 binary and selected the file and hit "convert" button, same message - file does not appear to be a comma delineated ascii file. I have been running MSCAD2004 for three months and have installed SP 8.1 and 9. Do I need to reinstall program from original cd. Do you think this will help?
Jeff
J. Heck
 

Postby rwhatman » Fri Sep 17, 2004 11:18 am

Jeff
Before you do a re-install

Check and see if you can download a file.

If you can. Try to upload the file you downloaded.

If this file loads then e-mail it to Microsurvey.

It may be just a simple format problem.

Just a thought.

Richard
rwhatman
 
Posts: 299
Joined: Sun Nov 10, 2002 6:41 am
Location: Peterborough, Ontario, Canada

I use TDS Software

Postby Kevin B. » Sat Sep 18, 2004 10:22 am

I use mscad2004 and an HP48Gx calculator with TDS software for my data collector. I create a cr5 file to upload by going to: MsPoints- Active Coordinate Editor- highlighting the points I want to upload-then click on file-write collector file out-TDS 48 & 500-file name-name it what I want, like 1019.cr5 in the folder you want. You have to name it with a cr5 extension or it won't work. I then go to MsTraverse-Data Collector Upload (to DC)-then make sure I have TDS 48/500/Husky named for the brand-pick my cr5 file to upload and follow the rest of the directions. This procedure works fine for me.
Kevin
Kevin B.
 
Posts: 36
Joined: Wed Mar 17, 2004 4:10 am
Location: Damariscotta, Maine

I think Kevin is right

Postby Darcy Detlor » Sun Sep 19, 2004 5:18 pm

I seem to recall (from many years ago) that the 48 did not require a binary cr5 file. The reason we added the binary cr5 file export was for the TDS on-board software in a Leica. It needed a binary cr5 file to be copied into the PCMCIA card that you inserted into the Total Station.
Darcy Detlor,
President,
MicroSurvey Software Inc.
darcy.detlor@microsurvey.com
User avatar
Darcy Detlor
Site Admin
 
Posts: 205
Joined: Tue Oct 29, 2002 10:14 am
Location: West Kelowna, BC

Tried Kevin's & Richard's Suggestions

Postby J. Heck » Mon Sep 20, 2004 8:00 pm

Keving,
Tried using active coordinate editor, highlighting coords., using write collector file out and saved as .cr5 file. When I went to upload, same message - file does not appear to be comma delineated .......
Richard
I am able to download a .cr5 to pc and to "read collector files" into drawing, then to upload same file (with file name changed so as not to overwrite) back to collector. The problem seems to be in the conversion of my data files to a format compatible with TDS. Any more suggestions?
Thanks
Jeff
J. Heck
 

CR5

Postby Glen Cameron » Tue Sep 21, 2004 5:05 am

Hi Jeff,

I got the CR5 file you emailed to me. I read your file into a new job in MSCAD2004 SP#9 and then did several tests.

What I found is the file you sent to me seems to have 8 decimal places for the N,E and Z fields.

When we export the CR5 file using any of the preset methods in our program, they are using 10 decimal places for the N,E and Z fields.

It is interesting that the files are only differing by 2 decimal places, but this may be the problem you are seeing on your end. It is also interesting that no other clients have had a problem with the files we generate. Is it possible to modify the way the TDS reads in the CR5 files? Maybe you have something set differently than the others.

Would you mind trying to upload the file I sent back to you? If it works then this will be a work around for you.

The file was created using the standard ASCII Export routine in MSCAD. I set the format to P,N,E,Z,D with 8 decimal places

Cheers,
Glen W. Cameron, C.E.T.
City of North Bay, Ontario
Glen Cameron
 
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada

tds transfer

Postby Vincent Popish » Tue Sep 21, 2004 6:05 am

You don't need to make a cr5 file for a 48, make a coma seperated file. Use export ascii under mspoints pull down menu, then transfer that to the 48. It works fine we have used it for years. But do not make a cr5 binary file , it is used for when you copy a file to a mem. card.
Vince Popish
Vincent Popish
 
Posts: 129
Joined: Thu Nov 14, 2002 11:24 am
Location: Grand Junction, CO

.cr5, .asc. txt it doesn't matter

Postby J.Heck » Wed Sep 22, 2004 7:01 pm

I appreciate all of the suggestions, but no matter what method I use to create the file - ascii export, write collector file, etc. and no matter what file extension I use *.cr5, *.asc, *.txt, *.*, I get the exact same result when I try to upload to DC (using the tds48/husky option or the tds .cr5 binary file option) "this file does not appear to be a comma delineated ascii file". The only way I can upload to my HP48GX (TDS) is to save the coordinates to an ascii file, export the file to a cogo program other than MSCAD2004, and upload from that program. I won't mention brand names here.

Jeff Heck
J.Heck
 

Please send me a pair of files

Postby Darcy Detlor » Wed Sep 22, 2004 7:04 pm

Hi there,

Can you please email a file that works and a file that does not work?

Send to darcy.detlor@microsurvey.com

I'll do a binary compare to see if there is any difference.
Darcy Detlor,
President,
MicroSurvey Software Inc.
darcy.detlor@microsurvey.com
User avatar
Darcy Detlor
Site Admin
 
Posts: 205
Joined: Tue Oct 29, 2002 10:14 am
Location: West Kelowna, BC

Solution

Postby Glen Cameron » Thu Sep 23, 2004 12:34 pm

For everyone else watching this thread, we found the problem!

I connected to Jeff's system via the internet and was able to examine his job. We found that the original ASCII file he was supplied from his client contained descriptions that had many extra spaces at the end of the actual description - then a comma after the spaces.

We can read this ASCII file into MSCAD of course but the point description then contains the extra spaces and the comma at the end. Normally this is not a problem, unless you need to export the points to a device that can not handle them.

When the TDS upload file was created it also contained these same characters. So when the file was to be uploaded, they caused a problem because it saw all the spaces and then the extra comma. This made it think it was not a normal TDS comma file because of having too many commas, etc. So it would not work.

Jeff is going to try and get a cleaned up file from his client as well as manually cleaning this file up - then try the upload again.

Thanks to everyone for their ideas and help - it helped eliminate many issues to help us narrow the search.

Cheers,
Glen W. Cameron, C.E.T.
City of North Bay, Ontario
Glen Cameron
 
Posts: 1395
Joined: Fri Nov 08, 2002 12:18 pm
Location: Corbeil, Ontario, Canada

Upload to TDS 48

Postby J. Heck » Thu Sep 23, 2004 4:31 pm

Hooray - problem solved. I cleaned up (removed extra spaces and commas) 20 points out of the coordinate file that I had been trying to upload and was able to send those points to the data collector (see posting from Glen Cameron above). I appreciate all the comments and suggestions that I received. They helped narrow the search. And to Microsurvey support staff, thanks for your patience and perseverance.

Jeff Heck
Give'm Heck, Inc.
J. Heck
 


Return to MicroSurvey CAD

Who is online

Users browsing this forum: No registered users and 4 guests

cron