MicroSurvey Software Inc. - Land Surveying and Data Collection Software
 

Layout Mode Made Easy (A.K.A. Paper Space)

Question: How do I print using Layout Mode ( Paper Space)?
Answer: Read the following TechNote for information.

Question: When I open a DWG file sent to me by an Architect (Engineer, Surveyor, Etc.), I cannot select any of the drawing entities without selecting everything in the drawing. When I Edit the entity information, it says it is type Viewport. What is this?
Answer: You are looking at a Viewport in Paper Space. The Architect (Engineer, Surveyor, Etc.) has sent you a drawing last saved in Paper Space.

Question: What do I need to do to edit the drawing for my own requirements?
Answer: Quite simply, you need to toggle the program from Layout Mode ( Paper Space) to Model Space. See Step #1 below for the appropriate commands.

The questions above have been asked many times by users just like you who are unfamiliar with this powerful tool. The following Tech Note will explain a simple way to use this tool to increase your productivity and simplify the printing process.

The image below represents a drawing that can be found in the \mscad2002 folder on your hard drive (It is called 3D Lots.FLX).

For this example, I have saved the file under a new name d:\jobs2000\TechNote Paper Space.FLX. The general configurations are as follows:

At this drawing scale, I want to print my lots on a 24" x 36" piece of paper. The area in which I want to place the drawing is 22" x 31.5". Prior to starting this tech note, I created a part (rectangle) at a 1:1drawing scale that is 22" x 31.5" and I can place this part on the drawing as pictured below. For more information on creating and inserting parts, please see Parts Demystified Technote. The image below shows the rectangle placed in the drawing and how the linework extends beyond the "printable area" defined by the rectangle.

If we were printing in Model Space and this rectangle defines the printable area of our title block, then we would have to manually trim the linework to fit the printable region. Fortunately, using Layout Mode and the View Manager will allow us to quickly and efficiently insert a tile block, define a new viewport and change contents of that viewport to a named view created using the View Manager. Sound daunting? Don't be afraid. Once you see the final product and how simple it is to get to that product, you will be using Layout Mode everyday.

The View Manager

The View Manager allows us to save multiple views of the same drawing for later use. The View Manager can be accessed from the View Pulldown menu by selecting View => View Manager. The following dialog box will appear.

fgfdg

We can create and recall previously saved views from this box. In this example, we will choose to create a new view by selecting the New button located in the dialog box.

We are then prompted to select either View or Window. Selecting View, prompts you for a name to save the current screen as. For this example, we want to select Window and draw a window around the rectangle (Using our Intersection Object Snap to ensure we trace the rectangle exactly). Once we have traced the window exactly on the rectangle, the following dialog box will appear and you can type in a view name. For this example, I choose the name PAPER_SPACE_TECHNOTE.

Your screen should now be zoomed to the view you have just selected.

Layout Mode

1. Now we need to insert our Title Block into Paper Space. To do this we need to toggle to Layout Mode and insert a part. To do this we can choose:

File => Layout Mode \ Model Space or select the button from your left toolbar. It is found above the IPN button. This will toggle you back and forth between Model Space and Layout Mode. You can also type the command TLMODE (you can also type TILEMODE and then set to 0 -many people know this from AutoCAD) at the command prompt. Having toggled to Layout Mode, you will be able to tell by glancing at the filename located at the top of your screen. The world Layout will appear right before the filename. I will now insert a title block I created prior to starting the technote. I created the part at a 1:1 drawing scale (Feet) so I Insert the part at the same scale. This is the nice thing about Layout Mode. Everything is at a 1:1 scale.

The following image shows the Inserted Title Block in Layout Mode.

The inside border of the Title Block is exactly 22" x 31.5". This matches the area of the rectangle we inserted in Model Space. We must now create a Viewport along this inside border similar to how we created the view in the View Manager. To do this, select File => Layout Viewport Control or the button from the left toolbar (You can also type VIEWPORT and the command prompt).

2. You will be presented with the following options:

In this instance, we are going to choose New and we will be prompted to select the corners of the viewport. As already mentioned, we will choose to select the inside border of our Title Block using our Object Snaps to trace the inside border exactly. The following image shows how your screen should look as you are "dragging" the window from the lower left to upper right of the inner border of the Title Block.

Once the viewport has been created, MicroSurvey will automatically bring the extents of your drawing (In Model Space) into the viewport. The figure below illustrates this.

This is, of course, not what we want to print.

3. To change the view we see through the viewport, we must first select it and then change the view to our previously stored view. To do this, select File => Layout Viewport Control or the button from the left tool bar. This will, once again, give you the options you see below.

In this instance, we want to select the View button from above and then select any element contained within the existing viewport. Once the viewport has been selected, you will be presented with the following option bar.

Now select the NView button as shown above. This will allow us to place our Named View (PAPER_SPACE_TECHNOTE) into the Viewport (See The View Manager above). The following dialog box will appear.

4. Highlight the stored view name and select OK. This will change the view in the viewport to the PAPER_SPACE_TECHNOTE view we saved earlier. You will then have a viewport which looks like this.

By clicking the right mouse button or by pressing the "Enter" or "Esc" key on your keyboard, you will return to paper space and should see the following image.

After inserting my North Arrow and Scale Bar, I am ready to print my drawing. That's it. This is how easy printing is in Paper Space. For more information on printing, see the following TechNote on Plotting Described and Made Easy. You will, of course, print at a 1 to 1 scale as this is the scale of paper space.

If you are required to print multiple views and multiple sheets, simply save the views using the view manager, insert the appropriate title blocks and create new viewports for each of the title blocks. You can then use the NVIEW button to change each of the views in the viewports to the appropriate stored (Named) view.

This TechNote just touches the surface of the power of Paper Space. As always, the best way to learn about the program is to take a few hours and play with the program using temporary files. I hope this allows you to increase your production by reducing the time necessary to print your drawings.

 

 

    SUPPORT